Southern Listeners

Thanks to Greenlava for this cool gadget. Get yours here

Monday, November 8, 2010

Remove "Showing newest posts with label..." Tag

When a label page is loaded, and if this page could not accommodate all of the labeled posts in a sinlge page (where you'd have to click 'Older Posts' to see previous posts), you'd be greeted with an annoying tag that that reads:

"Showing newest posts with label <label>. Show older posts"

If you are familiar with my previous tutorials, you would have seen a way to remove this tag. But I think this method deserves a dedicated tutorial for itself since it is a famous query when it comes to blog-tweaking.

In this tutorial, you will learn a very simple way to remove this annoying tag. Moreover, you will learn a way to fix the page margin as removing the label tag will create a gap in your page (in certain templates).

Step 1:

If you're using the old Blogger interface: Go to Dashboard - Design - Template Designer - Advanced - Add CSS - paste the following code - Press enter after the last character of the last line } - Apply to Blog.

If you're using the new Blogger interface: Go to Dashboard ('House' symbol) - Template - Customize - Advanced - Add CSS - paste the following code - Press enter after the last character of the last line } - Apply to Blog.
display: none;
You're done! The step below is optional.

Step 2:

Depending on your template, you might have your entire posts shifted a few pixels down. I've seen templates where this is not an issue, in fact most templates could adapt with it. But there are those which could not. The image below depicts the issue that I am talking about:

I was thinking of inlcuding the fix in this post itself, but I think it'd be better for me to generalize the idea and make a new tutorial for it. So you can check out how to fix this issue here.

Blogger Margin Fix

Happy getting rid of your "Showing newest...." tag!


  1. Thanks again! I really like not seeing that tag box =)

  2. Brilliant! Many thanks for that!

  3. Its not working for me..!! help

  4. @Bluetricks: I can't see the tag in your blog. In which page are you seeing this tag?

  5. I'm using Blogger's Simple template. Tried this method and it worked really well! My posts did not shift at all. Thanks to Yoboy, I have learnt many ways to tweak my blog. And I like that the site is not ENTIRELY filled with adverts like many out there (hurts my eyes!). I've made this site my go-to place whenever I need help tweaking my blog. Many thanks and keep up the good job!

    1. Hi there,

      Thanks for dropping some words and your feedback. Appreciate it :) Hope you enjoy your stay here..


  6. Hi,

    I've done this in my other blog before and it worked but I'm having trouble with it this time because I used my label link for my page tab. What should I do?

    1. Hi Debbie,

      The code should work even if you've placed the label in your pages gadget. The reason yours isn't working is because you've got a little piece of broken code in your template. It is preventing new CSS code from taking effect. Fix this broken code, and everything should be fine again. Took me forever to spot this little devil.

      Find for this line in your code:
      .title { font-family: "century gothic", verdana, arial;" }

      And change it to (remove the stray " at the end of the line)
      .title { font-family: "century gothic", verdana, arial;}

      That should do it. Cheers!

  7. Thank you so much! That tag really annoyed the crap out of me when I couldn't figure out what went wrong but I finally got it removed now. Can't believe a single quotation mark could mess everything up!

    Thanks again, really appreciate your help!

    1. I know right? The tiniest thing could cause the biggest headache. Have fun :)

  8. Hi Yoga, Thanks for your tips it worked for my blog but only applied to Home screen. Once I get into another, it appears as before. Can you help me?

    1. Hi Busana,

      That's odd.. let me have a look at your blog. What's your blog's address?

  9. Please, once you click one post youl'see there is 'showing post label,,,"

    1. Sorry for the late reply. I've seen your blog but I can't find the code in the tutorial above anywhere in your page. Did you save your template after adding the code above?

  10. Hi Yoga!

    I've made those changes, but all pages are not at the same levelwith each other. Actually only page being in original place/layout is that Runot label-page. I suppose it's because I've been using some gadgets onlyon certain pages? I can live with that, but after going different label pages next round (after 8 posts) mainpage and gadget are jumping strange way to each other again. I will hide those two last ones but they are still in use by links.

    And other problems: Is it possible to change all menu boxes to show different colour then you're on them? They don't work now like they should be. Only start page and the 3 last ones. working.

    And: I cant get the link page wider. I would like to keep the black area as the same layout as other pages but having wider about that gadget inside.

    1. Hi Kristian,

      Let's handle one thing at a time. I can see your elements jumping up and down across different label pages. Do uou happen to have specific conditional codes in your blog?

    2. Yes, I do. For gadgets (showing on certain pages or not show). Link page is based on bloglist gadget also. And I have changed mainpage layout with code.

    3. Hi Kristian,

      Sorry for the late reply. Can you copy and paste the conditional code that you have is and get back to me with its link?

    4. It's ok, Yoga.
      I'm in pastebin but have no clue what kind of options should have after code. BTW, with explorer site looks horrible.

    5. I keep missing your replies, I'm extremely sorry!

      Alright, let's try this. Upload a copy of your template somewhere so that I can have a look at what you're having. Go to Dashboard - Template - Backup/Restore - Download Full Template - Save the resulting xml file somewhere in your computer. Then go to and upload your xml file there. You will be given a link. Come back to this post and leave your link here.

  11. worked perfectly :-)
    Thank you so much! :-)


Please use the 'Ask a Question' page to shoot questions that are not related to the tutorial in the post above.